CSL planned maintenance 13/06/25 00:00 - 06:00

Incident Report for Legrand Care Cloud Service Status

Update

Apologies for any confusion; this will only affect CSL routers in schemes, not Reach Units. Downtime will also be extremely minimal in these cases.
Posted Jun 10, 2025 - 14:52 CEST

Update

Future planned maintenance for CSL during off peak hours. This can affect mobile reliant devices.
Posted Jun 10, 2025 - 13:29 CEST

Identified

Details: Planned Maintenance Notification – Internet Transit Provider (CSL)
Start Date & Time: June 13, 2025 00:00 BST
End Date & Time: June 13, 2025 06:00 BST
Services Impacted: CSL IoT Managed Router 4G, CSL IoT Managed Router Pro
Service Areas Impacted: Mobile Connectivity
Posted Jun 10, 2025 - 13:28 CEST
This incident affects: M2M (M2M Service).